Re: [mpich-discuss] Two problems about MPI_Publish_name/MPI_Loopup_name?
Hi, Ken, which version is your MPICH? My MPICH is 3.1.3. At 2015-01-30 04:34:51, "Kenneth Raffenetti" <[email protected]> wrote:
Haozi,
I'm not sure I understand the issue you are seeing. Can you include output from this code that illustrates the issue? I tried running with strings both less than and greater than 7 characters with no issue. The port_name is the same length in all cases on my laptop.
Ken
On 01/28/2015 01:56 AM, haozi wrote:
Hi, guys. My example code is the attachment.
1. What is the naming convention of service_name ? The hydra_nameserver CAN'T accept those strings whose length is less than 7. What's the exact naming convention?
2. The length of port_name by MPI_Loopup_name is different with MPI_Publish_name! You can test my code.
With best regards. Haozi
_______________________________________________ discuss mailing list [email protected] To manage subscription options or unsubscribe: https://lists.mpich.org/mailman/listinfo/discuss
_______________________________________________ discuss mailing list [email protected] To manage subscription options or unsubscribe: https://lists.mpich.org/mailman/listinfo/discuss
_______________________________________________ discuss mailing list [email protected] To manage subscription options or unsubscribe: https://lists.mpich.org/mailman/listinfo/discuss
participants (1)
-
haozi