I see the point, but this is one of the oldest parts of PETSc, and I am hesitant to change one
arbitrary name to another without a more convincing reason.
Matt
Lisandro has pointed out to me several times that the variable name PETSC_ARCH can be confusing; some people may think it is related to the architecture of the machine and don't understand that it is an arbitrary name that the user can make up. He suggested changing it to PETSC_CONF to be clearer.
Should we change it? Use something else?
Barry