As someone who believes in namespaces, it must be
x = PetscAdditionScalar(a,b);
As someone who believes that abbreviations are the work of the devil I would require x = Addition(a,b)
Barry
And since I don't believe in templates it would actually be x = AdditionScalar(a,b)
On Jul 27, 2012, at 7:02 PM, Sean Farley <sean@mcs.anl.gov> wrote:
> On Fri, Jul 27, 2012 at 6:20 PM, Jed Brown <five9a2@gmail.com> wrote:
>> By that logic, you should write +(a,b) instead of a+b. I'm looking forward
>> to if (!(rank)) {...}.
>
> Not really, just for functions whose names are more than one-character
> long. Duh.