On Sat, Jul 2, 2011 at 9:39 PM, Jed Brown <[email protected]> wrote:
In refactoring TS, I want these implementations to go away (they are special cases of TSTHETA and it's easy for TSTHETA to be as efficient for the special case). The question is whether the names should be preserved, with implementations that look like
TSCreate_BEuler(TS ts) { TSSetType(ts,TSTHETA); TSThetaSetTheta(ts,1.0); }
or just have users set this themselves. Thoughts?
It will be somewhat confusing in that Backwards Euler will not appear in the -ts_view. Maybe we could get a better name for the helper function. Matt -- What most experimenters take for granted before they begin their experiments is infinitely more interesting than any results to which their experiments lead. -- Norbert Wiener
participants (1)
-
Matthew Knepley