17 Jul
2008
17 Jul
'08
4:57 p.m.
Bill,
replace MPI_VOID_PTR_CAST_TO_MPI_AINT with (MPIR_Puint)
Shouldn't this be (MPI_Aint)(MPIR_Puint)? Otherwise, something like: x = MPI_VOID_PTR_CAST_TO_MPI_AINT(y) where x is an MPI_Aint would throw a warning because of a mismatch in size. Do we need to run this by IBM since this would essentially throw out 90% of their patches? -- Pavan -- Pavan Balaji http://www.mcs.anl.gov/~balaji