N.M. Maclaren wrote:
On Sep 14 2009, Bill Long wrote:
Craig Rasmussen wrote:
Please vote for one of the options. ...
I'm not convinced there is much real difference among these options.
I agree, though for slightly different reasons.
I think that all four are a mistake, because they are conflating all MPI integers into one. I would use two names, one for integers that may scale with memory size and one where that would be overkill.
Note that the wiki page includes a proposed MPI_COUNT_KIND, which I think is the integer kind that scales with memory size. I assumed this discussion was for integer arguments other than the ones for which kind=MPI_COUNT_KIND is specified. It would help if that were clarified, especially if my assumption is wrong. I agree with Nick that an independent kind constant is needed for the size cases.
4. Specify a named kind in the Fortran interface (MPI_INT_KIND) but allow the vendor a choice as to how to address integer promotion if users use default integers in their codes. ...
Again, I'm not really seeing the practical difference here.
Why should it be promotion, anyway? What if the default integer KIND is 64-bit and MPI_INT_KIND is 32-bit?
Right. "promotion" is a poor term here. "conversion" would be better. Cheers, Bill -- Bill Long [email protected] Fortran Technical Support & voice: 651-605-9024 Bioinformatics Software Development fax: 651-605-9142 Cray Inc., 1340 Mendota Heights Rd., Mendota Heights, MN, 55120