24 Jul
2013
24 Jul
'13
10:27 p.m.
Dmitry Karpeyev <[email protected]> writes:
Also, this is a minor point, but isn't SNESKSPEW_PreSolve() misnamed? It operates on a KSP and takes a SNES context, so shouldn't it be KSPPreSolve_SNESEW() or some such?
Yes, it is passed to KSPSetPreSolve, so it should be named something like KSPPreSolve_SNESEW.
Should we also fix SNESSkipConverged() --> SNESConvergedSkip() at the same time?
Yes, that was the intent of my last comment. It was missed when SNESDefaultConverged was renamed to SNESConvergedDefault.